Supported browsers

Internet Explorer - The earliest version supported is 10

Mozilla - The earliest version supported is 31

Safari -Tidigaste supported version is 7

Opera - The earliest version supported is 16

Chrome - The earliest version supported is 20

Javascript is required

In order to use the Build Safe requires that you have enabled JavaScript in your browser. Go into the settings of your browser to double check if JavaScript is enabled. JavaScript is enabled by default, usually.

Mobile devices

iOS - Earliest supported version is 9.0

Android - Earliest supported version is Lollipop 5.0

Did this answer your question?